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Categorizing pictures and videos by hash value
When evidence sources contain thousands of pictures and videos, looking at every picture and video, and
categorizing them one by one can be a very time consuming task. Import hash lists that contain known pictures and videos so that AXIOM Process automatically searches and categorizes these evidence sources
for you.
In addition to your own .txt files, you can import .json files from organizations like Project VIC and CAID,
which allow for the sharing of hash sets between law enforcement organizations for the purpose of identifying media related to child exploitation. When you import Project VIC hash lists, you can view additional
VICS metadata in AXIOM Examine such as tags, series, distributed media, identified victims, and more.
You can also enable PhotoDNA to use fuzzy matching to help identify even more pictures. With PhotoDNA
enabled, AXIOM Process can identify pictures that are similar in appearance to existing Project VIC pictures
and categorize them in the same way.
Select hash sets to use to categorize media
You can select the hash sets you want to use to categorize pictures and videos found in your evidence
sources. If you haven't previously imported hash lists, add hash lists and configure your hash sets first.
1. In AXIOM Process, click Processing details > Categorize pictures and videos.
2. In the Categorize pictures and videos by hash value table, select the hash sets you want
AXIOM Process to use to categorize evidence.
3. If applicable, clear the Enabled option next to any hash sets that you don't want to use for this search.
4. Continue setting up your case.
When your search completes, AXIOM Examine adds each category number it gets hits for to the Media categorizations filter. When you categorize media using Project VIC hash lists, you can view VICS attributes
and values in Media category details and filter by VICS attributes using the Media attributes (VICS) filter.
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Manage picture and video hash sets
To automatically categorize picture and video evidence by hash value, import hash lists. These lists can be
from organizations like Project VIC and CAID or your own files. Hash lists must be .json files or .txt files containing MD5, SHA1, or PhotoDNA hashes. For .txt files, each hash must be declared on its own line.
After you import a hash list, you can add the hash list to a new or existing hash set—for example, when you
want to update a Project VIC or CAID hash set with incremental updates downloaded from Hubstream.
Tip: If you haven't previously configured your hash sets in AXIOM Process, set up your media categorization profile in AXIOM Examine by choosing a media categorization list. You can choose pre-set
media categorization profiles for Canada (Project VIC), International (Project VIC), the United States
(Project VIC), and the United Kingdom (CAID), or you can add a new list or import a list of media categories. When you choose a media categorization list in AXIOM Examine, you'll see the category names
and colors you're familiar with when managing picture and video hash sets in AXIOM Process.
1. In AXIOM Process, click Processing details > Categorize pictures and videos.
2. In Categorize pictures and videos by hash value, click Add hash list.
3. In Step 1, click Select hash list.
4. Browse to the hash list you want to import and click Open.
5. In Step 2, complete one of the following options:
l
l

To add the imported hash list to an existing hash set, select the hash set you want to update.
To add the imported hash list to a new hash set, click Add new hash set. Provide a name for the
hash set and click Add.

6. In Step 3, complete one of the following options:
l

l

If the hash list you imported is a .txt file, from the drop-down, select the category you want to
update in the hash set and click Update hash set. Repeat for other categories you want to
update.
If the hash list you imported is a .json file, select the categories you want to update in the hash
set and click Update hash set.

7. When you've finished updating your hash sets, click Close.
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Set the priority of hash sets
The order of the hash sets in the Categorize pictures and videos by hash value table determines how AXIOM
Process categorizes pictures and videos when a matching hash value appears in more than one hash set
and has different categories applied to it. AXIOM Process will apply the assigned category from the hash set
with a higher priority.
1. In AXIOM Process, click Processing details > Categorize pictures and videos.
2. In the Categorize pictures and videos by hash value table, click the hash set whose priority you want
to change.
3. In the Priority column, click the up or down arrow to change the priority.
Enable PhotoDNA
If you import hash sets in AXIOM Process for the purpose of picture categorization, you can use PhotoDNA
and fuzzy matching to help identify more pictures. When you enable PhotoDNA, AXIOM Process can identify
pictures that have been modified to change their hash values and pictures that are similar in appearance to
existing Project VIC pictures.
PhotoDNA is only available to law enforcement. To request a password, visit www.magnetforensics.com/photodnaregistration.
1. In AXIOM Process, on the Tools menu, click Settings.
2. In Hashing > Enable photo DNA, provide the password that you received from Magnet Forensics.
3. Click Okay.

Categorize pictures and videos manually
In addition to automatically categorizing pictures and videos using hash sets, you can manually categorize
or grade these artifacts in AXIOM Examine in the Thumbnail view. You can quickly grade images and videos
using keyboard shortcuts and bulk categorization options.
If you haven't previously configured a media categorization list, AXIOM Examine prompts you to choose one.
You can choose pre-set media categorization profiles for Canada (Project VIC), International (Project VIC),
the United States (Project VIC), and the United Kingdom (CAID) or you can add a new list or import a list of
media categories.
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1. In AXIOM Examine, open the Artifacts explorer.
2. In the View drop-down list, click Thumbnail view.
3. Select the pictures or videos you want to apply a media category to.
4. In Media categories, click the media category you want to apply, or press the keyboard shortcut (09) for the media category you want to apply.
5. Repeat Steps 3-4 for any other pictures and videos you want to categorize.
Apply a media category to uncategorized pictures or videos
You can quickly apply a media category to all uncategorized pictures or videos that are currently visible in
the Thumbnail view. After you apply a category to all uncategorized media, AXIOM Examine automatically
displays the next set of uncategorized evidence so you can continue to applying media categories.
1. In AXIOM Examine, open the Artifacts explorer.
2. In the View drop-down list, click Thumbnail view.
3. In Media categories, in the Set all visible uncategorized pictures to drop-down, select a media category.
4. Click Categorize or press the PLUS SIGN (+).

Update hash sets with media categorizations from a case
After you manually categorize pictures and videos in your case, you can add reviewer graded media back
to your hash sets in the Magnet AXIOM hash database for use with future cases. The next time you create a
case in AXIOM Process and search the evidence using these updated hash sets, AXIOM Process will automatically search and categorize evidence with matching hashes for you.
1. In AXIOM Examine, on the Process menu, click Update hash set with new media categorizations.
2. In Step 1: Select a hash set to update, complete one of the following options:
l
l

To add the hash list to an existing hash set, select the hash set you want to update.
To add the hash list to a new hash set, click Add new hash set. Provide a name for the hash set
and click Add.

3. In Step 2: Select the categories to update in the hash set, select the categories you want to update in
the hash set and click Update hash set.
4. When you've finished updating your hash sets, click Close.
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Export media categorizations from a case to Project VIC or CAID
After you've categorized pictures and videos in your case, you can create a JSON export of the reviewer
graded media to share with Project VIC or CAID. You can select the media items you want to include in the
export such as reviewer graded media. If you've enabled a pre-set media categorization country profile, the
following categories are included in the export by default:
l

Canada (Project VIC): Category 1

l

International (Project VIC): Categories 1-2

l

United Kingdom (CAID): All categories except 8

l

United States (Project VIC): Categories 1-3

After you choose the category metadata you want to include, select the subset of categories you want to
include attachments for in the export. Your export will include a .json file and a folder with attachments for
included metadata items.
1. In AXIOM Examine, on the File menu, click Create report / export.
2. In the Export type drop-down list, click VICS 1.3 or VICS 2.0.
3. Next to the File path field, click Browse and select the location you want to save the export. Click
Select folder.
4. In Items to include, select the media options you want to include in your export.
5. In Contact information, provide your contact information so that another organizations can contact
you if they get a match on one of your identifiers.
6. Click Create.

Managing media categories
Select a media categorization list to use
The media categorization list you select determines which categories are available for media categorization in AXIOM Examine. You can choose pre-set media categorization profiles for Canada (Project
VIC), International (Project VIC), the United States (Project VIC), and the United Kingdom (CAID), or you can
add a new list or import a list of media categories.
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1. In AXIOM Examine, click Tools > Manage media categories.
2. Select the media categorization list you want to use.
3. Click Okay.
Create a custom list of media categories
You can add a media categorizations list in AXIOM Examine to create a custom list of categories. Your list
can contain up to 10 categories, and you can provide custom names and colors for each category.
1. In AXIOM Examine, click Tools > Manage media categories.
2. Click Add new list.
3. Click the Active option next to the list you created.
4. In the List name field, provide a name for your media categorization list.
5. Complete any of the following actions to customize your media categorization list:
l

To change the color of a category, click the current color and then choose a new color.

l

To change the name of a category, click the current name and provide a new name.

l

To turn off any categories you don't want to use, clear the Enabled option.

6. Optionally, select the default category you want to use to assign all visible uncategorized pictures to.
7. Click Okay.
Import a media categorization list
You can import a list of media categorizations in AXIOM Examine. Files must be XML format.
1. In AXIOM Examine, click Tools > Manage media categories.
2. Click Import list.
3. Browse to the XML file you want to import.
4. Click Open.
5. Click the Active option next to the list you created.
6. In the List name field, provide a name for your media categorization list.
7. Complete any of the following actions to customize your media categorization list:
l

To change the color of a category, click the current color and then choose a new color.

l

To change the name of a category, click the current name and provide a new name.
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l

To turn off any categories you don't want to use, clear the Enabled option.

8. Optionally, select the default category you want to use to assign all visible uncategorized pictures to.
9. Click Okay.
Export a media categorization list
Export your list of media categorizations to share with other examiners. Media categorization lists export in
XML format.
1. In AXIOM Examine, click Tools > Manage media categories.
2. Select the media categorization list you want to export.
3. Click Export list.
4. Browse to the location you want to save the list.
5. Click Save.

Find matching or similar pictures in your case
When you enable PhotoDNA, AXIOM Process assigns a PhotoDNA hash to each valid picture in your case. In
addition to finding matching pictures with identical hashes, PhotoDNA also uses fuzzy matching to find similar pictures with slight modifications. Using this technique, a user can modify a picture by re-sizing, cropping, drawing over, adding a watermark, or changing the resolution, and PhotoDNA can identify it as similar
to the original picture. PhotoDNA works by converting pictures into a black-and-white format, dividing them
into squares, and calculating a numerical value for each square. These values, which represent the shading
in each square, are the PhotoDNA signature or hash of a picture.
1. In AXIOM Examine, in the Artifacts explorer, click a picture artifact.
2. In Details > Artifact Information, find the picture's PhotoDNA hash (alongside its MD5 and SHA1
hashes).
3. Right-click the artifact and click Find similar pictures.
4. In the Find similar pictures dialog, select one of the following options:
l

l

To find the exact same, unmodified pictures, click Exact match: This option has the same functionality as MD5 and SHA1 hashes.
To find a similar picture file that might be a modified version of the selected one, click Similar
match.

5. Click Search.
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AXIOM Examine filters on matching or similar pictures and shows you the results.

Recategorize media files in your case
If you categorized your media for Project VIC using a third-party tool, you can import the .json files to apply
those categorizations to the media in your case after initial processing.
1. In AXIOM Examine, on the Process menu, click Categorize pictures and videos by hash value.
2. When AXIOM Process opens, browse to Processing details > Categorize pictures and videos.
3. In Categorize pictures and videos by hash value, click Add file.
4. Browse to the location where you saved the .json file and click Open.
5. If applicable, clear the Enabled option next to any previously imported .json files that you don't want
to use for this search.
6. Click Analyze evidence.
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